System Status

Realtime System Status

Situation in Ukraine

Incident Report for CommPeak

Resolved

This incident has been resolved.
Posted Mar 13, 2022 - 16:35 UTC

Identified

Due to the ongoing situation in Ukraine and Russia, our offices in Ukraine have a limited availability. Our offices in Manila (and others) work normally and handle all our support and operational manners of CommPeak with no operational impact.

Please expect limited support only in Ukrainian and Russian languages.
Posted Feb 24, 2022 - 08:55 UTC
This incident affected: Headquarters.