System Status

Realtime System Status

TextPeak Outage

Incident Report for CommPeak

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 17:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2025 - 16:05 UTC

Investigating

We are currently experiencing a major outage affecting our TexPeak. Our engineering team is actively working to resolve the issue as quickly as possible. Thank you for your patience
Posted Jul 17, 2025 - 15:32 UTC
This incident affected: SMS Gateway.