System Status

Realtime System Status
PBX Stats System Maintenance
Scheduled for Feb 28, 06:00 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 25, 2021 - 13:32 UTC
Scheduled
We will be performing maintenance work for our PBX Stats. During the maintenance period, you may experience inaccessibility issues. We will do our best to minimize the impact and its duration.
Posted Feb 23, 2021 - 15:09 UTC
This scheduled maintenance affects: Phone system (Hosted IP-PBX) (PBX Stats).