System Status

Realtime System Status

We are investigating the issue causing the current outage

Incident Report for CommPeak

Resolved

This incident has been resolved
Posted Dec 05, 2025 - 09:23 UTC

Monitoring

The issue originates with our vendor, Cloudflare. They have deployed a fix and are monitoring its effectiveness.
Posted Dec 05, 2025 - 09:17 UTC

Investigating

Our team is actively investigating the ongoing outage and working toward a resolution
Posted Dec 05, 2025 - 09:12 UTC
This incident affected: my.commpeak.com (my.commpeak.com), Phone system (Hosted IP-PBX) (PBX Stats), Dialer Web - Europe 4 (Web Application), Dialer Web - Europe 1 (Web Application), Dialer Web - Europe 2 (Web Application), Dialer Web - Asia (Web Application), Dialer Web - America (Web Application), and Dialer Web - Europe 3 (Web Application).