Realtime System Status
Realtime Dashboard Outage
Incident Report for CommPeak
Resolved
This incident has been resolved.
Posted Sep 23, 2019 - 06:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2019 - 06:48 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2019 - 06:35 UTC
This incident affected: Phone system (Hosted IP-PBX) (PBX Stats).