System Status

Realtime System Status
Support System Outage
Incident Report for CommPeak
Resolved
Our support system provider has informed that the majority of functionality has been restored to normal. We are fully available at all support channels.
Posted Feb 22, 2024 - 13:12 UTC
Monitoring
Our support system provider has informed that the major outage is resolved. Webchat and email support is back to operational. We are continuing to monitor the situation.
Posted Feb 22, 2024 - 11:10 UTC
Identified
Our support system provider is currently partially available which affects our support teams operation, we are working in order to provide a backup solution for it.
This issue does not affect our services.
Posted Feb 22, 2024 - 10:01 UTC
This incident affected: my.commpeak.com (my.commpeak.com), Phone system (Hosted IP-PBX) (PBX Stats), commpeak.com, Dialer Web - Europe 4 (Web Application), Dialer Web - Europe 1 (Web Application), Dialer Web - Europe 2 (Web Application), Dialer Web - Asia (Web Application), Dialer Web - America (Web Application), and Dialer Web - Europe 3 (Web Application).