The incident has been resolved and all services are operating normally.
Posted Nov 18, 2025 - 17:53 UTC
Monitoring
We can see that our third-party provider, Cloudflare, is in the process of recovering, although some issues may still persist. We will continue to monitor the situation closely and are working on a long-term workaround to prevent similar problems in the future. Some of these workarounds have already been implemented, while others are currently in progress.
Posted Nov 18, 2025 - 15:08 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:01 UTC
Investigating
We have confirmed that the issue lies with our third-party provider, Cloudflare. While they proceed with remediation, our team is researching alternative means to bypass the dependency.
Posted Nov 18, 2025 - 11:59 UTC
This incident affected: my.commpeak.com (my.commpeak.com), commpeak.com, SMS Gateway, Dialer Web - Europe 4 (Web Application), Dialer Web - Europe 1 (Web Application), Dialer Web - Europe 2 (Web Application), Dialer Web - Asia (Web Application), Dialer Web - America (Web Application), and Dialer Web - Europe 3 (Web Application).