System Status

Realtime System Status
Global Network Issue
Incident Report for CommPeak
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:15 UTC
Monitoring
A fix was applied, we are monitoring the result.
Posted Jun 21, 2022 - 07:32 UTC
Identified
The issue is related to our CDN provider Cloudflare, we are working on a fix.
Posted Jun 21, 2022 - 07:07 UTC
Investigating
We are experiencing issues with network connectivity for our systems. We believe this is related to a more widespread outage across the internet and are investigating.
Posted Jun 21, 2022 - 06:54 UTC
This incident affected: my.commpeak.com (my.commpeak.com, Free Trial Registration), Phone system (Hosted IP-PBX) (PBX Stats), commpeak.com, Dialer Web - Europe 4 (Web Application), Dialer Web - Europe 1 (Web Application), Dialer Web - Europe 2 (Web Application), Dialer Web - Asia (Web Application), Dialer Web - America (Web Application), and Dialer Web - Europe 3 (Web Application).